PT-2018-13711
CVE-2018-16733
·
Published
2018-09-08
·
Updated
2025-08-08
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions
Go Ethereum versions prior to 1.8.14
Description
The issue arises from improper input validation in the TraceChain function within the eth/api tracer.go file. Specifically, it does not verify that the end block is after the start block. This affects the github.com/ethereum/go-ethereum/eth package.
Recommendations
For versions prior to 1.8.14, update to version 1.8.14 or later to resolve the issue. As a temporary workaround, consider validating block ranges manually to ensure the end block is after the start block until a patch is applied. Restrict access to the TraceChain function in the eth/api tracer.go file to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾