PT-2018-14277

CVE-2018-17927

·

Published

2018-10-11

·

Updated

2019-10-09

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Delta Industrial Automation TPEditor versions 1.90 and prior
Description The issue is related to multiple out-of-bounds write vulnerabilities that can be exploited by processing specially crafted project files. These files lack user input validation, which may cause the system to write outside the intended buffer area and may allow remote code execution.
Recommendations For versions 1.90 and prior, update to a version later than 1.90 to resolve the issue. As a temporary workaround, consider restricting the processing of project files from untrusted sources until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ZDI-18-1235
ZDI-18-1237
ZDI-18-1239
ZDI-18-1245
Found an issue in the description? Have something to add? Feel free to write us 👾