PT-2018-14480

CVE-2018-18478

·

Published

2018-10-18

·

Updated

2022-05-14

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions LibreNMS versions prior to 1.44
Description The issue allows remote attackers to inject arbitrary web script or HTML via the dashboard name parameter in the "/ajax form.php" API endpoint, related to files such as "html/includes/forms/add-dashboard.inc.php", "html/includes/forms/delete-dashboard.inc.php", and "html/includes/forms/edit-dashboard.inc.php".
Recommendations For versions prior to 1.44, update to version 1.44 or later to resolve the issue. As a temporary workaround, consider restricting access to the "/ajax form.php" endpoint or avoiding the use of the dashboard name parameter until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-9M82-F3WX-P625
Found an issue in the description? Have something to add? Feel free to write us 👾