PT-2018-16160

CVE-2018-3736

·

Published

2018-07-27

·

Updated

2018-07-27

Description by

CVSS 3.1
9.1
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Name of the Vulnerable Software and Affected Versions https-proxy-agent versions prior to 2.2.0
Description The issue is related to a denial of service caused by unsanitized options, specifically proxy.auth, being passed to Buffer().
Recommendations Update to version 2.2.0 or later.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-8G7P-74H8-HG48
Found an issue in the description? Have something to add? Feel free to write us 👾