PT-2018-16488

CVE-2018-4220

·

Published

2018-06-08

·

Updated

2019-10-03

Description by

CVSS 2.0
9.3
High
MetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Swift versions prior to 4.1.1 Security Update 2018-001
Description The issue involves the "Swift for Ubuntu" component and allows attackers to execute arbitrary code in a privileged context. This is possible because write and execute permissions are enabled during library loading.
Recommendations For versions prior to 4.1.1 Security Update 2018-001, update to Swift 4.1.1 Security Update 2018-001 to resolve the issue. As a temporary workaround, consider restricting the use of the "Swift for Ubuntu" component until the update is applied.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾