PT-2018-16824

CVE-2018-5233

·

Published

2018-03-19

·

Updated

2022-05-14

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Grav CMS versions prior to 1.3.0
Description A cross-site scripting (XSS) issue allows remote attackers to inject arbitrary web script or HTML via the PATH INFO to the "admin/tools" endpoint. This is due to a vulnerability in the system/src/Grav/Common/Twig/Twig.php file.
Recommendations For Grav CMS versions prior to 1.3.0, update to version 1.3.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the "admin/tools" endpoint until a patch is available. Avoid using the PATH INFO to inject arbitrary data into the admin/tools endpoint until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-977G-93F5-RQJX
Found an issue in the description? Have something to add? Feel free to write us 👾