PT-2018-1824
CVE-2018-1000301
·
Published
2018-05-16
·
Updated
2026-09-18
Description by
CVSS 3.1
9.1
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Name of the Vulnerable Software and Affected Versions:
curl versions 7.20.0 through 7.59.0
Description:
The issue is related to a buffer over-read vulnerability that can result in a denial of service. This occurs when curl is tricked into reading data beyond the end of a heap-based buffer used to store downloaded RTSP content. The vulnerability is exploited when servers send RTSP responses back to curl, and the data is parsed to separate it into headers. The
Curl http readwrite headers() function may leave a pointer pointing into the buffer instead of to the start of the buffer, leading to an out-of-buffer read when code assumes that pointer points to a full buffer size worth of memory to use. This could potentially lead to information leakage but most likely a crash or denial of service for applications if a server triggers this flaw.Recommendations:
For curl versions 7.20.0 through 7.59.0, update to version 7.60.0 or later to resolve the issue.
As a temporary workaround, consider restricting access to RTSP content until the issue is resolved.
Found an issue in the description? Have something to add? Feel free to write us 👾