PT-2018-2557

CVE-2018-16510

·

Published

2018-08-27

·

Updated

2024-06-15

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Artifex Ghostscript versions prior to 9.24
Description An issue in Artifex Ghostscript allows remote attackers to supply crafted PDFs, potentially crashing the interpreter or having other unspecified impacts. The vulnerability is caused by incorrect exec stack handling in the "CS" and "SC" PDF primitives and a buffer overflow in memory, which could allow an attacker to impact the confidentiality, integrity, and availability of protected information using a specially crafted PDF file.
Recommendations For versions prior to 9.24, update to version 9.24 or later to resolve the issue. As a temporary workaround, consider restricting the use of the "CS" and "SC" PDF primitives until a patch is available. Avoid processing untrusted or specially crafted PDF files with affected versions of Artifex Ghostscript.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2018-2799
MGASA-2018-0378
OPENSUSE-SU-2018_3036-1
OPENSUSE-SU-2018_3038-1
OPENSUSE-SU-2024:10783-1
SUSE-SU-2018:2975-1
SUSE-SU-2018:2975-2
SUSE-SU-2018:2975-3
SUSE-SU-2018:2976-1
USN-3768-1
USN-3773-1
Found an issue in the description? Have something to add? Feel free to write us 👾