PT-2018-2615

CVE-2018-16850

·

Published

2018-07-30

·

Updated

2026-09-18

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions PostgreSQL versions prior to 11.1 PostgreSQL versions prior to 10.6
Description The issue is related to SQL injection in pg upgrade and pg dump via CREATE TRIGGER ... REFERENCING. An attacker can cause arbitrary SQL statements to run with superuser privileges by using a purpose-crafted trigger definition. The vulnerability is due to a lack of protection of the SQL query structure, allowing a remote attacker to execute arbitrary SQL commands.
Recommendations For versions prior to 11.1, update to version 11.1 or later to resolve the issue. For versions prior to 10.6, update to version 10.6 or later to resolve the issue. As a temporary workaround, consider restricting the use of CREATE TRIGGER ... REFERENCING in pg upgrade and pg dump until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2018-2606
ALT-PU-2018-2607
ALT-PU-2018-2608
CLEANSTART-2026-FW42039
CLEANSTART-2026-HJ04971
CLEANSTART-2026-QP57180
OPENSUSE-SU-2018_3893-1
OPENSUSE-SU-2018_4031-1
OPENSUSE-SU-2024:11184-1
OPENSUSE-SU-2024:11185-1
RHSA-2018:3757
SUSE-SU-2018:3770-1
SUSE-SU-2018_3770-1
SUSE-SU-2018:3770-2
SUSE-SU-2018_3770-2
SUSE-SU-2018:3942-1
USN-3818-1
Found an issue in the description? Have something to add? Feel free to write us 👾