PT-2018-2652

CVE-2018-17082

·

Published

2018-07-06

·

Updated

2024-06-15

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.6.38 PHP versions 7.0.x prior to 7.0.32 PHP versions 7.1.x prior to 7.1.22 PHP versions 7.2.x prior to 7.2.10
Description The issue allows for cross-site scripting (XSS) via the body of a "Transfer-Encoding: chunked" request due to mishandling of the bucket brigade in the php handler function. This can be exploited by a remote attacker to perform a cross-site scripting attack.
Recommendations For PHP versions prior to 5.6.38, update to version 5.6.38 or later. For PHP versions 7.0.x prior to 7.0.32, update to version 7.0.32 or later. For PHP versions 7.1.x prior to 7.1.22, update to version 7.1.22 or later. For PHP versions 7.2.x prior to 7.2.10, update to version 7.2.10 or later.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALT-PU-2018-2369
DLA-1509-1
DSA-4353-1
OPENSUSE-SU-2018_2929-1
OPENSUSE-SU-2018_3056-1
OPENSUSE-SU-2018_3062-1
OPENSUSE-SU-2022_4067-1
OPENSUSE-SU-2024:11167-1
OPENSUSE-SU-2024:11169-1
RHSA-2019:2519
SUSE-SU-2018:2887-1
SUSE-SU-2018_2887-1
SUSE-SU-2018:3016-1
SUSE-SU-2018_3016-1
SUSE-SU-2018:3017-1
SUSE-SU-2018_3017-1
SUSE-SU-2018:3018-1
SUSE-SU-2018_3018-1
SUSE-SU-2022:4067-1
USN-3766-1
Found an issue in the description? Have something to add? Feel free to write us 👾