PT-2018-2693

CVE-2018-18584

·

Published

2018-10-22

·

Updated

2026-09-30

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions libmspack versions prior to 0.8alpha cabextract versions prior to 1.8
Description The issue is related to an out-of-bounds write in the CAB block input buffer, which can be exploited by a remote attacker to execute arbitrary code or cause a denial of service. The problem arises because the buffer is one byte too small for the maximal Quantum block.
Recommendations For libmspack versions prior to 0.8alpha, update to version 0.8alpha or later to resolve the issue. For cabextract versions prior to 1.8, update to version 1.8 or later to resolve the issue.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2021-1110
ALT-PU-2021-1165
ALT-PU-2023-1005
ALT-PU-2023-1663
ALT-PU-2024-8946
ALT-PU-2025-1563
ALT-PU-2025-1661
CESA-2019_2049
CLEANSTART-2023-RR06614
DLA-1555-1
MGASA-2018-0455
OPENSUSE-SU-2024:13619-1
RHSA-2019:2049
RHSA-2019_2049
SUSE-SU-2019:0748-1
SUSE-SU-2019_0748-1
SUSE-SU-2019:13992-1
SUSE-SU-2019_13992-1
SUSE-SU-2020:2711-1
SUSE-SU-2020_2711-1
USN-3814-1
USN-3814-2
USN-3814-3
Found an issue in the description? Have something to add? Feel free to write us 👾