PT-2018-2733
CVE-2018-4181
·
Published
2018-07-11
·
Updated
2020-04-08
Description by
CVSS 3.1
5.5
MediumMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions
macOS High Sierra versions prior to 10.13.5
Description
The issue is related to the CUPS print server and involves improper handling of certain include directives, allowing an unprivileged user to read arbitrary files as a superuser. This enables an attacker to access confidential data. The problem was addressed by improving access restrictions.
Recommendations
For macOS High Sierra versions prior to 10.13.5, update to version 10.13.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the CUPS service until the update is applied.
Found an issue in the description? Have something to add? Feel free to write us 👾