PT-2018-3005
CVE-2019-3855
·
Published
2018-12-03
·
Updated
2026-10-14
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
libssh2 versions prior to 1.8.1
Description
The issue is related to an integer overflow in the libssh2 library, which can be exploited by a remote attacker to execute arbitrary code on the client system when a user connects to a compromised SSH server. The vulnerability is associated with the
libssh2 transport read function in the src/transport.c file and occurs when reading packets from the server.Recommendations
For libssh2 versions prior to 1.8.1, update to version 1.8.1 or later to resolve the issue. As a temporary workaround, consider restricting access to SSH servers until the update is applied. Avoid using the
libssh2 transport read function until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾