PT-2018-3014
CVE-2018-12385
·
Published
2018-09-21
·
Updated
2024-12-12
Description by
CVSS 3.1
7.0
HighMetricsAV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Thunderbird versions prior to 60.2.1
Firefox ESR versions prior to 60.2.1
Firefox versions prior to 62.0.2
Description
The issue is related to a potentially exploitable crash in TransportSecurityInfo used for SSL, which can be triggered by data stored in the local cache in the user profile directory. This problem is only exploitable in combination with another vulnerability that allows an attacker to write data into the local cache or from locally installed malware. Additionally, it can cause a non-exploitable startup crash for users switching between the Nightly and Release versions of Firefox if the same profile is used. The vulnerability is associated with insufficient input validation in the TransportSecurityInfo component.
Recommendations
For Thunderbird versions prior to 60.2.1, update to version 60.2.1 or later.
For Firefox ESR versions prior to 60.2.1, update to version 60.2.1 or later.
For Firefox versions prior to 62.0.2, update to version 62.0.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾