PT-2018-3104
CVE-2018-6140
·
Published
2018-01-02
·
Updated
2024-06-15
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Google Chrome versions prior to 67.0.3396.62
Description
The issue concerns the chrome.debugger API in Google Chrome's DevTools, which allowed an attacker to execute arbitrary code via a crafted Chrome Extension if they convinced a user to install it. The vulnerability exists due to insufficient input validation in the Debugger API component, potentially allowing a remote attacker to execute arbitrary code using a specially crafted Chrome Extension.
Recommendations
For versions prior to 67.0.3396.62, update to version 67.0.3396.62 or later to resolve the issue. As a temporary workaround, consider disabling the use of the chrome.debugger API in DevTools until the update is applied. Restrict access to installing extensions to minimize the risk of exploitation. Avoid using the chrome.debugger API for attaching to Web UI pages in DevTools until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾