PT-2018-3178
CVE-2018-1301
·
Published
2018-03-21
·
Updated
2026-10-09
Description by
CVSS 3.1
5.9
MediumMetricsAV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Apache HTTP Server versions prior to 2.4.30
Description
A specially crafted request could crash the server due to an out of bound access after a size limit is reached by reading the HTTP header. This issue is considered very hard if not impossible to trigger in non-debug mode, so it is classified as low risk for common server usage. The issue is related to an out of bound access in memory after reaching the size limit by reading the HTTP header, which could allow a remote attacker to cause a denial of service.
Recommendations
For versions prior to 2.4.30, update to version 2.4.30 or later to resolve the issue. As a temporary workaround, consider restricting access to the server or implementing additional security measures to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾