PT-2018-3209

CVE-2018-16802

·

Published

2018-09-10

·

Updated

2024-06-15

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Artifex Ghostscript versions prior to 9.25
Description The issue exists due to insufficient input validation in the Ghostscript software, which can allow an attacker to execute arbitrary code by supplying crafted PostScript. This is related to incorrect "restoration of privilege" checking when running out of stack during exception handling, specifically with the use of the "pipe" instruction.
Recommendations For Artifex Ghostscript versions prior to 9.25, update to version 9.25 or later to resolve the issue. As a temporary workaround, consider restricting the use of crafted PostScript to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2018-2344
CESA-2018_3834
DLA-1504-1
DSA-4294-1
MGASA-2018-0378
OPENSUSE-SU-2018_3036-1
OPENSUSE-SU-2018_3038-1
OPENSUSE-SU-2024:10783-1
RHSA-2018:3834
RHSA-2018_3834
SUSE-SU-2018:2975-1
SUSE-SU-2018:2975-2
SUSE-SU-2018:2975-3
SUSE-SU-2018:2976-1
USN-3768-1
Found an issue in the description? Have something to add? Feel free to write us 👾