PT-2018-3210

CVE-2018-17183

·

Published

2018-09-16

·

Updated

2024-06-15

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Artifex Ghostscript versions prior to 9.25
Description The issue arises from insufficient input validation in the Ghostscript software, allowing remote attackers who can supply crafted PostScript to potentially overwrite or replace error handlers and inject code. This could enable an attacker to execute arbitrary code.
Recommendations For versions prior to 9.25, update to version 9.25 or later to resolve the issue. As a temporary workaround, consider restricting access to the Ghostscript software to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2018-2344
CESA-2018_3834
DLA-1527-1
DSA-4294-1
OPENSUSE-SU-2018_3036-1
OPENSUSE-SU-2018_3038-1
OPENSUSE-SU-2018_4138-1
OPENSUSE-SU-2018_4140-1
OPENSUSE-SU-2024:10783-1
RHSA-2018:3834
RHSA-2018_3834
SUSE-SU-2018:2975-1
SUSE-SU-2018:2975-2
SUSE-SU-2018:2975-3
SUSE-SU-2018:2976-1
SUSE-SU-2018:4087-1
SUSE-SU-2018_4087-1
SUSE-SU-2018:4090-1
SUSE-SU-2018_4090-1
SUSE-SU-2018:4090-2
SUSE-SU-2018_4090-2
USN-3773-1
Found an issue in the description? Have something to add? Feel free to write us 👾