PT-2018-3225
CVE-2018-5712
·
Published
2018-01-08
·
Updated
2020-04-08
Description by
CVSS 2.0
6.4
MediumMetricsAV:N/AC:L/Au:N/C:P/I:P/A:N
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.6.33
PHP versions 7.0.x prior to 7.0.27
PHP versions 7.1.x prior to 7.1.13
PHP versions 7.2.x prior to 7.2.1
Description
The issue is related to Reflected XSS on the PHAR 404 error page via the URI of a request for a .phar file. This occurs due to insufficient protection measures for the web page structure, allowing a remote attacker to perform cross-site scripting attacks.
Recommendations
For PHP versions prior to 5.6.33, update to version 5.6.33 or later.
For PHP versions 7.0.x prior to 7.0.27, update to version 7.0.27 or later.
For PHP versions 7.1.x prior to 7.1.13, update to version 7.1.13 or later.
For PHP versions 7.2.x prior to 7.2.1, update to version 7.2.1 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾