PT-2018-3437
CVE-2018-5819
·
Published
2018-11-22
·
Updated
2024-06-15
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions:
LibRaw versions prior to 0.19.1
Description:
The issue is related to the
parse sinar ia() function in the LibRaw library, which is used for image processing. It is associated with an uncontrolled resource consumption. Exploitation of this issue may allow a remote attacker to cause a denial of service by exhausting available CPU resources.Recommendations:
For versions prior to 0.19.1, update to version 0.19.1 or later to resolve the issue.
As a temporary workaround, consider disabling the
parse sinar ia() function until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾