PT-2018-3444
CVE-2018-19639
·
Published
2018-11-29
·
Updated
2024-06-15
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
supportutils versions prior to 3.1-5.7.1
Description:
The issue is related to the supportutils package for SUSE Linux, where an attacker can exploit the vulnerability by manipulating the rpm listing, allowing them to execute arbitrary commands as root. This can be achieved when supportutils is run with the -v option to perform rpm verification.
Recommendations:
For versions prior to 3.1-5.7.1, update to version 3.1-5.7.1 or later to resolve the issue. As a temporary workaround, consider avoiding the use of the -v option for rpm verification until a patch is available. Restrict access to the rpm listing to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾