PT-2018-3461

CVE-2017-18266

·

Published

2018-05-10

·

Updated

2024-06-15

Description by

CVSS 2.0
9.3
High
MetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions: xdg-utils versions prior to 1.1.3
Description: The issue is related to the open envvar function in xdg-open, which does not properly validate strings before launching the program specified by the BROWSER environment variable. This could allow remote attackers to conduct argument-injection attacks via a crafted URL. For example, using %s in the BROWSER environment variable could lead to such an attack. The vulnerability might also allow a remote attacker to gain unauthorized access to information and disrupt its integrity and availability.
Recommendations: For versions prior to 1.1.3, update to version 1.1.3 or later to resolve the issue. As a temporary workaround, consider validating the strings passed to the open envvar function or restricting the use of the BROWSER environment variable to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2018-1958
DLA-1384-1
DSA-4211-1
MGASA-2018-0289
OPENSUSE-SU-2018_1596-1
OPENSUSE-SU-2024:11518-1
SUSE-SU-2018:1497-1
SUSE-SU-2018_1497-1
USN-3650-1
Found an issue in the description? Have something to add? Feel free to write us 👾