PT-2018-3466

CVE-2018-16540

·

Published

2018-08-23

·

Updated

2024-06-15

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: Artifex Ghostscript versions prior to 9.24
Description: The issue is related to a use-after-free in copydevice handling when processing crafted PostScript files with the builtin PDF14 converter. This could allow attackers to crash the interpreter or potentially have other unspecified impacts. Exploitation of the vulnerability may enable an attacker to cause a denial of service using a specially crafted PostScript file.
Recommendations: For versions prior to 9.24, update to version 9.24 or later to resolve the issue. As a temporary workaround, consider restricting the use of the builtin PDF14 converter until a patch is available. Avoid processing untrusted or specially crafted PostScript files with the affected converter to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2018-2344
CESA-2019_0229
DLA-1504-1
DSA-4288-1
MGASA-2018-0378
OPENSUSE-SU-2018_3036-1
OPENSUSE-SU-2018_3038-1
OPENSUSE-SU-2024:10783-1
RHSA-2019:0229
RHSA-2019_0229
SUSE-SU-2018:2975-1
SUSE-SU-2018:2975-2
SUSE-SU-2018:2975-3
SUSE-SU-2018:2976-1
SUSE-SU-2018:3330-1
USN-3768-1
Found an issue in the description? Have something to add? Feel free to write us 👾