PT-2018-3467

CVE-2018-15908

·

Published

2018-08-21

·

Updated

2024-06-15

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: Artifex Ghostscript versions prior to 9.23
Description: The issue is related to insufficient access control in the .tempfile component of the Ghostscript software suite for document processing, conversion, and generation. Exploitation of this issue may allow an attacker to bypass the -dSAFER protection, delete files, or gain unauthorized access to protected information using a specially crafted PostScript file. Attackers can supply malicious PostScript files to bypass .tempfile restrictions and write files.
Recommendations: For Artifex Ghostscript versions prior to 9.23, update to version 9.23 or later to resolve the issue. As a temporary workaround, consider restricting access to the .tempfile component until a patch is available. Avoid using specially crafted PostScript files that could exploit this issue until the software is updated.
Exploitability
Fix
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2018-2344
CESA-2018_3650
DLA-1504-1
DSA-4288-1
MGASA-2018-0378
OPENSUSE-SU-2018_3036-1
OPENSUSE-SU-2018_3038-1
OPENSUSE-SU-2024:10783-1
RHSA-2018:3650
RHSA-2018_3650
SUSE-SU-2018:2975-1
SUSE-SU-2018:2975-2
SUSE-SU-2018:2975-3
SUSE-SU-2018:2976-1
USN-3768-1
Found an issue in the description? Have something to add? Feel free to write us 👾