PT-2018-3611
CVE-2018-13346
·
Published
2018-07-05
·
Updated
2024-06-15
Description by
CVSS 4.0
8.7
HighMetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
Mercurial versions prior to 4.6.1
Description
The issue is related to the
mpatch apply function in mpatch.c, which incorrectly proceeds when the fragment start is past the end of the original data. This is due to a lack of input validation. Exploitation of this issue may allow a remote attacker to impact data integrity.Recommendations
For Mercurial versions prior to 4.6.1, update to version 4.6.1 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
mpatch apply function until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾