PT-2018-3779

CVE-2018-16831

·

Published

2018-04-26

·

Updated

2022-05-14

Description by

CVSS 2.0
7.1
High
MetricsAV:N/AC:M/Au:N/C:C/I:N/A:N
Name of the Vulnerable Software and Affected Versions Smarty versions prior to 3.1.33-dev-4
Description The issue is related to a flaw in the processing of the $trusted dir array, which is part of the trusted directory protection mechanism. This flaw can be exploited by attackers to bypass the protection and gain unauthorized access to sensitive information. The exploitation involves using a file:./../ substring in an include statement, allowing access to files outside the intended directory. For example, an attacker could use the file:./../../../../../etc/passwd path to access sensitive system files.
Recommendations For versions prior to 3.1.33-dev-4, update to version 3.1.33-dev-4 or later to resolve the issue. As a temporary workaround, consider restricting the use of the include statement with the file:./../ substring to minimize the risk of exploitation. Additionally, review and limit access to sensitive files and directories to prevent unauthorized access.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-65J5-VPM7-6XP4
DLA-2618-1
MGASA-2022-0127
USN-5348-1
Found an issue in the description? Have something to add? Feel free to write us 👾