PT-2018-3827
CVE-2018-5801
·
Published
2018-01-16
·
Updated
2024-06-15
Description by
CVSS 2.0
7.1
HighMetricsAV:N/AC:M/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
LibRaw versions prior to 0.18.7
Description
The issue is related to errors in pointer dereferencing within the LibRaw library for image processing, specifically in the src/libraw cxx.cpp component. This can be exploited by a remote attacker to cause a denial of service. The
LibRaw::unpack() function is particularly affected, allowing for a NULL pointer dereference.Recommendations
For versions prior to 0.18.7, update to version 0.18.7 or later to resolve the issue.
As a temporary workaround, consider restricting the use of the
LibRaw::unpack() function until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾