PT-2018-3831

CVE-2018-5800

·

Published

2018-01-16

·

Updated

2022-01-29

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions LibRaw versions prior to 0.18.7
Description The issue is related to an off-by-one error within the LibRaw::kodak ycbcr load raw() function in the internal/dcraw common.cpp component of the LibRaw library. This error can lead to a heap-based buffer overflow, causing a crash. The vulnerability can be exploited by a remote attacker to cause a denial of service.
Recommendations For versions prior to 0.18.7, update to version 0.18.7 or later to resolve the issue. As a temporary workaround, consider restricting the use of the LibRaw::kodak ycbcr load raw() function until a patch is applied.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2018-1064
CESA-2018_3065
DLA-1734-1
DLA-2903-1
RHSA-2018:3065
RHSA-2018_3065
SUSE-SU-2018:3343-1
SUSE-SU-2018_3343-1
USN-3615-1
Found an issue in the description? Have something to add? Feel free to write us 👾