PT-2018-4156

CVE-2014-10067

·

Published

2018-05-29

·

Updated

2020-08-31

Description by

CVSS 3.1
5.9
Medium
MetricsAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions paypal-ipn versions 2.x.x and earlier paypal-ipn versions prior to 3.0.0
Description The issue concerns a validation bypass vulnerability. paypal-ipn uses the test ipn parameter, set by the PayPal IPN simulator, to determine whether to use the production PayPal site or the sandbox. An attacker could craft a request using the simulator to fool an application into entering sandbox mode, potentially allowing purchases without valid payment.
Recommendations For versions 2.x.x and earlier, upgrade to version 3.0.0 or later. As a temporary workaround, consider explicitly checking for the test ipn parameter in production to prevent validation bypass.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-H698-R4HM-W94P
Found an issue in the description? Have something to add? Feel free to write us 👾