PT-2018-4403

CVE-2015-5725

·

Published

2018-02-21

·

Updated

2018-03-14

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions CodeIgniter versions prior to 2.2.4
Description The issue allows remote attackers to execute arbitrary SQL commands. This is due to a SQL injection vulnerability in the offset method in the Active Record class. The vulnerability can be exploited via vectors involving the offset variable.
Recommendations For versions prior to 2.2.4, update to version 2.2.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the offset method in the Active Record class to minimize the risk of exploitation. Avoid using the offset variable in sensitive queries until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾