PT-2018-4551

CVE-2015-9238

·

Published

2018-05-31

·

Updated

2019-10-09

Description by

CVSS 2.0
5.0
Medium
MetricsAV:N/AC:L/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions secure-compare versions prior to 3.0.1
Description The issue arises from the secure-compare function comparing the first argument with itself instead of comparing two different strings. This results in the function always returning true when comparing two strings of the same length, regardless of their actual contents.
Recommendations For versions prior to 3.0.1, upgrade to version 3.0.1 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-H9X2-5RM7-X4GM
Found an issue in the description? Have something to add? Feel free to write us 👾