PT-2018-4872
CVE-2016-10694
·
Published
2018-06-04
·
Updated
2019-10-09
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
alto-saxophone versions prior to 2.25.1
Description
The issue concerns the insecure download of binary resources over HTTP, making it susceptible to man-in-the-middle (MITM) attacks. An attacker with a privileged network position could intercept the response and replace the executable with a malicious one, potentially leading to remote code execution (RCE) on the system running the software.
Recommendations
Update to version 2.25.1 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾