PT-2018-4935

CVE-2016-6169

·

Published

2018-02-07

·

Updated

2018-02-24

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Foxit Reader versions 7.3.4.311 and earlier PhantomPDF versions 7.3.4.311 and earlier
Description The issue is related to a heap-based buffer overflow that can be triggered by the Bezier data in a crafted PDF file, potentially leading to memory corruption, application crash, or arbitrary code execution.
Recommendations For Foxit Reader versions 7.3.4.311 and earlier, update to a version later than 7.3.4.311 to resolve the issue. For PhantomPDF versions 7.3.4.311 and earlier, update to a version later than 7.3.4.311 to resolve the issue. As a temporary workaround, consider avoiding the use of crafted PDF files that contain malicious Bezier data until a patch is available.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾