PT-2018-5765
CVE-2017-15105
·
Published
2018-01-22
·
Updated
2024-06-15
Description by
CVSS 3.1
5.3
MediumMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions:
unbound versions prior to 1.6.8
Description:
A flaw was found in the way unbound validated wildcard-synthesized NSEC records. An improperly validated wildcard NSEC record could be used to prove the non-existence of an existing wildcard record, or trick unbound into accepting a NODATA proof.
Recommendations:
For versions prior to 1.6.8, update to version 1.6.8 or later to resolve the issue. As a temporary workaround, consider restricting the use of wildcard NSEC records until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾