PT-2018-6033

CVE-2017-16003

·

Published

2018-05-29

·

Updated

2019-10-09

Description by

CVSS 2.0
9.3
High
MetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions: windows-build-tools versions prior to 1.0.0
Description: The issue concerns the insecure download of resources over HTTP, making it susceptible to man-in-the-middle (MITM) attacks. If an attacker is positioned on the network or between the user and the remote server, they may swap the requested resources with an attacker-controlled copy, potentially leading to remote code execution (RCE). This can occur when an attacker intercepts the response and replaces the executable with a malicious one, resulting in code execution on the system running the affected software.
Recommendations: Update to version 1.0.0 or later.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-9P47-W5XP-F4XR
Found an issue in the description? Have something to add? Feel free to write us 👾