PT-2018-6112
CVE-2017-16083
·
Published
2018-06-07
·
Updated
2019-10-09
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions:
node-simple-router versions prior to 0.10.1
Description:
The issue allows an attacker to access the filesystem by exploiting a directory traversal vulnerability. This can be achieved by placing "../" in the URL, giving access to files outside of the intended directory root, potentially resulting in the disclosure of private files on the vulnerable system. For example, a malicious actor can send a request like "GET /../../../../../../../../../../etc/passwd HTTP/1.1" to access sensitive files.
Recommendations:
Update to version 0.10.1 or later. As a temporary workaround, consider restricting access to sensitive files and directories to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾