PT-2018-6140

CVE-2017-16111

·

Published

2018-06-07

·

Updated

2019-10-09

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions: content versions prior to 3.0.6
Description: The issue affects the content module, which is used by the hapijs framework to parse HTTP Content-* headers. It is vulnerable to regular expression denial of service when passed specifically crafted Content-Type or Content-Disposition headers.
Recommendations: Update to version 3.0.6 or later.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-X6WP-RFWH-HCX7
Found an issue in the description? Have something to add? Feel free to write us 👾