PT-2018-6144
CVE-2017-16117
·
Published
2018-06-07
·
Updated
2019-10-09
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions:
slug versions prior to 0.9.2
Description:
The issue concerns a regular expression denial of service in the slug module when specially crafted untrusted input is passed. This can cause the event loop to block for 2 seconds with approximately 50,000 characters.
Recommendations:
Update to version 0.9.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾