PT-2018-6255
CVE-2017-16226
·
Published
2018-06-07
·
Updated
2019-10-09
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
static-eval versions prior to 2.0.0
Description:
The issue allows untrusted user input to access the global function constructor, effectively enabling arbitrary code execution. This occurs because affected versions of the static-eval module pass user input directly to the global function constructor when parsing expressions via the package.
Recommendations:
Update to version 2.0.0 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾