PT-2018-6534

CVE-2017-17557

·

Published

2018-04-24

·

Updated

2018-06-05

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: Foxit Reader versions prior to 9.1 Foxit PhantomPDF versions prior to 9.1
Description: A flaw exists in the parsing of the BITMAPINFOHEADER record in BMP files due to the lack of proper validation of the biSize member. This can result in a heap-based buffer overflow, allowing an attacker to execute code in the context of the current process.
Recommendations: For Foxit Reader versions prior to 9.1, update to version 9.1 or later. For Foxit PhantomPDF versions prior to 9.1, update to version 9.1 or later.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾