PT-2018-7107

CVE-2017-2293

·

Published

2018-02-01

·

Updated

2022-01-24

Description by

CVSS 2.0
5.5
Medium
MetricsAV:N/AC:L/Au:S/C:N/I:P/A:P
Name of the Vulnerable Software and Affected Versions: Puppet Enterprise versions prior to 2016.4.5 Puppet Enterprise versions prior to 2017.2.1
Description: The issue concerns a configuration in MCollective that allows the package plugin to install or remove arbitrary packages on all managed agents. This configuration poses a risk as it can be exploited to compromise the security of the system. The estimated number of potentially affected devices is not specified. There is no information about real-world incidents where this issue was exploited.
Recommendations: For versions prior to 2016.4.5, update to version 2016.4.5 or later to resolve the issue. For versions prior to 2017.2.1, update to version 2017.2.1 or later to resolve the issue. As a temporary workaround, consider changing the default policy to not allow the package plugin to install or remove arbitrary packages on all managed agents.
Exploitability
Fix
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾