PT-2018-9265

CVE-2018-1000086

·

Published

2018-03-13

·

Updated

2026-02-18

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: Pym.js versions 0.4.2 through 1.3.1
Description: The issue concerns a Cross Site Request Forgery (CSRF) vulnerability in the onNavigateToMessage function of Pym.js. This can result in arbitrary JavaScript code execution. The attack is exploitable when an attacker gains full JavaScript access to pages with Pym.js embeds or when a user visits an attacker-crafted page.
Recommendations: For Pym.js versions 0.4.2 through 1.3.1, update to version 1.3.2 or later to resolve the issue. As a temporary workaround, consider disabling the onNavigateToMessage function until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-82GW-PQF7-Q3J2
RSEC-2026-0
Found an issue in the description? Have something to add? Feel free to write us 👾