PT-2018-9333

CVE-2018-1000162

·

Published

2018-04-18

·

Updated

2022-03-30

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Parsedown versions prior to 1.7.0
Description The issue concerns a Cross Site Scripting (XSS) vulnerability in the setMarkupEscaped function for escaping HTML, which can result in JavaScript code execution. This can be exploited via specially crafted markdown that allows it to bypass HTML escaping by breaking Abstract Syntax Tree (AST) boundaries.
Recommendations For versions prior to 1.7.0, update to version 1.7.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of the setMarkupEscaped function until a patch is available. Avoid using specially crafted markdown that can break AST boundaries in the affected function until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-QGPV-86R3-87FH
Found an issue in the description? Have something to add? Feel free to write us 👾