PT-2018-9398
CVE-2018-1000404
·
Published
2018-07-09
·
Updated
2022-05-13
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Jenkins AWS CodeBuild Plugin versions 0.26 and earlier
Description
The issue is related to insufficiently protected credentials in the
AWSClientFactory.java and CodeBuilder.java files, which can lead to credentials disclosure. This can be exploited via local file access.Recommendations
For Jenkins AWS CodeBuild Plugin versions 0.26 and earlier, update to version 0.27 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾