PT-2019-10285

CVE-2018-20858

·

Published

2019-08-09

·

Updated

2019-08-21

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions: Recommender versions prior to 1.3.1
Description: The issue allows for cross-site scripting (XSS), which can be exploited by a learner crafting a fake resource that includes a script. This script could potentially steal credentials from staff if they are lured into viewing the recommended resource.
Recommendations: For versions prior to 1.3.1, update to version 1.3.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the recommender feature until a patch is available. Avoid using the recommender feature with untrusted resources to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-3J5X-7CCF-PPGM
PYSEC-2019-219
Found an issue in the description? Have something to add? Feel free to write us 👾