PT-2019-11500
CVE-2019-1010183
·
Published
2019-07-25
·
Updated
2020-08-24
Description by
CVSS 3.1
6.5
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions:
serde yaml versions 0.6.0 through 0.8.3
Description:
The issue is related to Uncontrolled Recursion, which can cause a denial of service by aborting. This occurs when the
from * functions, specifically all deserialization functions, parse a malicious YAML file.Recommendations:
For versions 0.6.0 through 0.8.3, update to version 0.8.4 or later to resolve the issue. As a temporary workaround, consider restricting the parsing of YAML files from untrusted sources to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾