PT-2019-11646

CVE-2019-10231

·

Published

2019-03-27

·

Updated

2020-08-24

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: Teclib GLPI versions prior to 9.4.1.1
Description: The issue allows bypass of authentication due to a PHP type juggling vulnerability. This occurs in the checkPassword() function, which is located in the auth.class.php file.
Recommendations: For versions prior to 9.4.1.1, update to version 9.4.1.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the Auth::checkPassword() function until a patch is available.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾