PT-2019-12279

CVE-2019-11393

·

Published

2019-04-21

·

Updated

2019-04-30

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions M/Monit versions prior to 3.7.3
Description An issue was discovered in the "/admin/users/update" API endpoint. It allows unprivileged users to escalate their privileges to an administrator by requesting a password change and specifying the admin parameter.
Recommendations For versions prior to 3.7.3, update to version 3.7.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the "/admin/users/update" API endpoint to prevent privilege escalation.
Exploitability
Exploit
Fix
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾