PT-2019-12400
CVE-2019-11590
·
Published
2019-04-29
·
Updated
2020-08-24
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
10Web Form Maker plugin versions prior to 1.13.5
Description
The issue allows for CSRF via the "wp-admin/admin-ajax.php" action parameter, potentially leading to local file inclusion through directory traversal. This is due to a discrepancy between the
$ POST['action'] value and the $ GET['action'] value, where the latter is unsanitized.Recommendations
For versions prior to 1.13.5, update to version 1.13.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the "wp-admin/admin-ajax.php" endpoint to minimize the risk of exploitation. Avoid using unsanitized
$ GET['action'] values in the affected endpoint until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾