PT-2019-12497

CVE-2019-11807

·

Published

2019-05-06

·

Updated

2020-08-24

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions WooCommerce Checkout Manager plugin versions prior to 4.3
Description The issue allows media deletion due to a lack of capabilities checks and a nopriv registration. This can be exploited via the "wp-admin/admin-ajax.php?action=update attachment wccm" API endpoint, specifically through the wccm default keys load parameter.
Recommendations For versions prior to 4.3, update to version 4.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the "wp-admin/admin-ajax.php?action=update attachment wccm" API endpoint to minimize the risk of exploitation. Avoid using the wccm default keys load parameter in the affected API endpoint until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾